Februar 2020

Flutter - Failed to download the Android dependencies

Nachdem ich in den letzen Tagen immer wieder Problem mit Flutter hatte, habe ich heute morgen entscheiden, Flutter mal ganz neu zu installieren. Dabei bin ich exakt wie unter https://flutter.dev/docs/get-started/install/macos beschrieben vorgegangen und bis zu Schritt 4 (Optionally, pre-download development binaries:) gekommen.

Der Befehl flutter precache ist immer wieder mit der Fehlermeldung “Failed to download the Android dependencies” abgebrochen. Jetzt kann man natürlich sagen, OK, der Schritt ist ja optional, aber leider ist er das nicht wirklich. Lässt man den Schritt hier weg, landet man spätestens beim kompilieren einer Flutter App wieder bei dem Problem.

Um etwas mehr details über das Problem zu bekommen habe ich dann den Befehl “flutter precache” mal mit der “Verbose” Option gestartet und mir mal angesehen, was da im Detail falsch läuft.… Weiterlesen