Heimautomatisierung und IoT erfordern es gelegentlich, dass man eine sichere Verbindung über das Internet in das heimische Netz benötigt. Dafür gibt es schon Lösungen, die mehr oder weniger sicher sind. Eine beliebte Lösung ist es, den Fernzugriff im heimischen Router zu konfigurieren (Anleitung z.B. hier). Diese Methode funktioniert gut, ist aber nicht immer ganz sicher. Eine Alternative für den Fernzugriff auf den heimischen Raspberry Pi bietet jetzt TeamViewer.

TeamViewer Fernwartungssoftware

TeamViewer ist eine Fernwartungssoftware für Screen-Sharing, Videokonferenzen, Dateitransfer und VPN. Die Software arbeitet als Online-Dienst durch Firewalls und NAT sowie Proxy-Server hindurch. TeamViewer funktioniert nur mit der Internetprotokoll-Version 4. Im Gegensatz zu VNC nutzt es ein proprietäres Protokoll, dass die höchsten Sicherheitsstandards (256-Bit AES Session Encoding, 2048-Bit RSA Key Exchange) unterstützt und aktuell auf mehr als 200.000.000 Computern installiert ist.
So wie es scheint, möchte Teamviewer nun in die neue Welt des IoT/der Heimautomatisierung einsteigen und sich hier ein weiteres Tätigkeitsfeld erschließen.

TeamViewer für Raspberry Pi

Bisher war TeamViewer nur für den PC verfügbar und ist den Meisten (Hobby-)Administratoren bekannt als eine schnelle und einfache Lösung, bei Oma mal wieder alles in Ordnung zu bringen :-). Nun hat Teamviewer nach langem Wehklagen der Community eine erste preview Version (teamviewer-host_11.0.58397_armhf.deb) für den Raspberry Pi erstellt. Damit ist es nun endlich ermöglicht die Steuerung aller Heimautomatisierung und IoT-Anwendungen die über den Raspberry Pi erreichbar sind mit der Teamviewer-Lösung Remote zu erreichen.

Der Teamviewer Host für den Raspberry Pi ist als ein Systemdienst konstruiert, der einen Zugang über das Internet auf die Raspberry Pi-Geräte ermöglicht.

Auf der Webseite unter https://www.teamviewer.com/iotcontest/#infos gibt Teamviewer folgende System-Requirements an:

  • Raspberry Pi 2 or Raspberry Pi 3 (Raspberry Pi 1 and Zero currently not supported)
  • Raspbian 8.0 Wheezy with X-Server or Framebuffer VT
  • 35 MB disk space

Teamviewer Host für den Raspberry Pi Features

  • Fernbedienung des Raspberry Pi von einem beliebigen anderen Gerät
  • Verbindung zum Raspberry Pi über eine grafische Oberfläche oder über den Headless Modus (Weitere Infos zum Headless Modus)
  • Problemloser Betrieb hinter Firewalls und Proxy-Servern
  • Wahlweise ein dynamisches oder festes Passwort für den Zugang auf den Raspberry Pi per TeamViewer
  • Weitere Funktionen für die folgenden Versionen geplant.

Download TeamViewer für Raspberry Pi unter: https://www.teamviewer.com/iotcontest/

Teamviewer Host für den Raspberry Pi im Test

Ich habe mir die Preview Version des Teamviewer Host für den Raspberry Pi natürlich direkt heruntergeladen und zum Glück auch gerade einen ganz frischen Raspberry Pi 3 zu Hause herumliegen. Was liegt also näher, das „deb-Paket“ direkt mal zu installieren?

Erst mal kopiere ich die teamviewer-host_11.0.58397_armhf.deb Datei auf die SD Karte des Raspberry Pi. Dafür nutze ich einen USB Stick, auf dem ich die deb-Datei schon mal heruntergeladen habe. Dann führe ich folgendes Kommando aus.

sudo dpkg -i teamviewer-host_11.0.58397_armhf.deb 

Leider hat der TeamViewer ein paar Abhängigkeiten, die ich noch installieren muss. Daher scheitert die Installation mit dem Fehler:

pi@raspberrypi:~ $ sudo dpkg -i teamviewer-host_11.0.58397_armhf.deb 
Selecting previously unselected package teamviewer-host.
(Reading database ... 127554 files and directories currently installed.)
Preparing to unpack teamviewer-host_11.0.58397_armhf.deb ...
Unpacking teamviewer-host (11.0.58397) ...
dpkg: dependency problems prevent configuration of teamviewer-host:
 teamviewer-host depends on libqt5gui5 (>= 5.2.1); however:
  Package libqt5gui5 is not installed.
 teamviewer-host depends on libqt5widgets5 (>= 5.2.1); however:
  Package libqt5widgets5 is not installed.
 teamviewer-host depends on libqt5qml5 (>= 5.2.1); however:
  Package libqt5qml5 is not installed.
 teamviewer-host depends on libqt5quick5 (>= 5.2.1); however:
  Package libqt5quick5 is not installed.
 teamviewer-host depends on libqt5webkit5 (>= 5.1.1); however:
  Package libqt5webkit5 is not installed.
 teamviewer-host depends on qtdeclarative5-qtquick2-plugin (>= 5.2.1) | qml-module-qtquick2 (>= 5.2.1); however:
  Package qtdeclarative5-qtquick2-plugin is not installed.
  Package qml-module-qtquick2 is not installed.
 teamviewer-host depends on qtdeclarative5-controls-plugin (>= 5.2.1) | qml-module-qtquick-controls (>= 5.2.1); however:
  Package qtdeclarative5-controls-plugin is not installed.
  Package qml-module-qtquick-controls is not ins
dpkg: error processing package teamviewer-host (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 teamviewer-host

Leider ist libqt5 nicht im Raspberry Repository enthalten, aber nach kurzem Suchen finde ich ein Repository, dass mir weiterhelfen könnte. ( https://twolife.be/raspbian/)

Um die Pakete aus dem Repo nutzen zu können, trage ich den URL in die sources.list ein und trage den Schlüssel in den Schlüsselbund ein. Auch wenn ich dabei eigentlich kein so gutes Gefühl habe …

pi@raspberrypi:~ $ sudo vi /etc/apt/sources.list
pi@raspberrypi:~ $ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-key 2578B775
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.GZ2EzctpD1 --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-key 2578B775
gpg: requesting key 2578B775 from hkp server keyserver.ubuntu.com
gpg: key 2578B775: public key "S?bastien Noel " imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)

Nun funktioniert die Installation von libQT5 aber ohne Probleme

pi@raspberrypi:~ $ sudo apt-get install libqt5qml5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libqt5qml5 : Depends: libdouble-conversion1 but it is not going to be installed
 teamviewer-host : Depends: libqt5quick5 (>= 5.2.1) but it is not going to be installed
                   Depends: libqt5webkit5 (>= 5.1.1) but it is not going to be installed
                   Depends: qtdeclarative5-qtquick2-plugin (>= 5.2.1) but it is not installable or
                            qml-module-qtquick2 (>= 5.2.1) but it is not going to be installed
                   Depends: qtdeclarative5-controls-plugin (>= 5.2.1) but it is not installable or
                            qml-module-qtquick-controls (>= 5.2.1) but it is not going to be installed
                   Depends: qtdeclarative5-dialogs-plugin (>= 5.2.1) but it is not installable or
                            qml-module-qtquick-dialogs (>= 5.2.1) but it is not going to be installed
                   Depends: qtdeclarative5-window-plugin (>= 5.2.1) but it is not installable or
                            qml-module-qtquick-window2 (>= 5.2.1) but it is not going to be installed
                   Depends: qtdeclarative5-quicklayouts-plugin (>= 5.2.1) but it is not installable or
                            qml-module-qtquick-layouts (>= 5.2.1) but it is not going to be installed
                   Recommends: ttf-liberation but it is not going to be installed or
                               fonts-liberation but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
pi@raspberrypi:~ $ sudo apt-get -f install           
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libasn1-8-heimdal libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal
  libhx509-5-heimdal libkrb5-26-heimdal libroken18-heimdal libwind0-heimdal
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libdouble-conversion1 libqt5opengl5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5sql5
  libqt5sql5-sqlite libqt5webkit5 qml-module-qtquick-controls qml-module-qtquick-dialogs
  qml-module-qtquick-layouts qml-module-qtquick-privatewidgets qml-module-qtquick-window2
  qml-module-qtquick2
The following NEW packages will be installed:
  libdouble-conversion1 libqt5opengl5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5sql5
  libqt5sql5-sqlite libqt5webkit5 qml-module-qtquick-controls qml-module-qtquick-dialogs
  qml-module-qtquick-layouts qml-module-qtquick-privatewidgets qml-module-qtquick-window2
  qml-module-qtquick2
0 upgraded, 14 newly installed, 0 to remove and 19 not upgraded.
1 not fully installed or removed.
Need to get 10.8 MB of archives.
After this operation, 44.2 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
  libqt5qml5 libqt5quick5 libqt5opengl5 libqt5printsupport5 libqt5sql5 libqt5webkit5 qml-module-qtquick2
  qml-module-qtquick-layouts qml-module-qtquick-window2 qml-module-qtquick-controls
  qml-module-qtquick-privatewidgets qml-module-qtquick-dialogs libqt5sql5-sqlite
Install these packages without verification? [y/N] y
Get:1 https://twolife.be/raspbian/ jessie/qt libqt5qml5 armhf 5.5.1-3+rpi10 [1002 kB]
Get:2 http://mirrordirector.raspbian.org/raspbian/ jessie/main libdouble-conversion1 armhf 2.0.1-1 [32.3 kB]
Get:3 https://twolife.be/raspbian/ jessie/qt libqt5quick5 armhf 5.5.1-3+rpi10 [888 kB]
Get:4 https://twolife.be/raspbian/ jessie/qt libqt5opengl5 armhf 5.5.1+dfsg-10+rpi10 [124 kB]
Get:5 https://twolife.be/raspbian/ jessie/qt libqt5printsupport5 armhf 5.5.1+dfsg-10+rpi10 [170 kB]
Get:6 https://twolife.be/raspbian/ jessie/qt libqt5sql5 armhf 5.5.1+dfsg-10+rpi10 [105 kB]
Get:7 https://twolife.be/raspbian/ jessie/qt libqt5webkit5 armhf 5.5.1+dfsg-2+rpi10 [7661 kB]
Get:8 https://twolife.be/raspbian/ jessie/qt qml-module-qtquick2 armhf 5.5.1-3+rpi10 [41.1 kB]               
Get:9 https://twolife.be/raspbian/ jessie/qt qml-module-qtquick-layouts armhf 5.5.1-2 [25.4 kB]              
Get:10 https://twolife.be/raspbian/ jessie/qt qml-module-qtquick-window2 armhf 5.5.1-3+rpi10 [21.8 kB]       
Get:11 https://twolife.be/raspbian/ jessie/qt qml-module-qtquick-controls armhf 5.5.1-2 [606 kB]             
Get:12 https://twolife.be/raspbian/ jessie/qt qml-module-qtquick-privatewidgets armhf 5.5.1-2 [33.1 kB]      
Get:13 https://twolife.be/raspbian/ jessie/qt qml-module-qtquick-dialogs armhf 5.5.1-2 [80.2 kB]             
Get:14 https://twolife.be/raspbian/ jessie/qt libqt5sql5-sqlite armhf 5.5.1+dfsg-10+rpi10 [46.6 kB]          
Fetched 10.8 MB in 7s (1363 kB/s)                                                                            
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously unselected package libdouble-conversion1:armhf.
(Reading database ... 128344 files and directories currently installed.)
Preparing to unpack .../libdouble-conversion1_2.0.1-1_armhf.deb ...
Unpacking libdouble-conversion1:armhf (2.0.1-1) ...
Selecting previously unselected package libqt5qml5:armhf.
Preparing to unpack .../libqt5qml5_5.5.1-3+rpi10_armhf.deb ...
Unpacking libqt5qml5:armhf (5.5.1-3+rpi10) ...
Selecting previously unselected package libqt5quick5:armhf.
Preparing to unpack .../libqt5quick5_5.5.1-3+rpi10_armhf.deb ...
Unpacking libqt5quick5:armhf (5.5.1-3+rpi10) ...
Selecting previously unselected package libqt5opengl5:armhf.
Preparing to unpack .../libqt5opengl5_5.5.1+dfsg-10+rpi10_armhf.deb ...
Unpacking libqt5opengl5:armhf (5.5.1+dfsg-10+rpi10) ...
Selecting previously unselected package libqt5printsupport5:armhf.
Preparing to unpack .../libqt5printsupport5_5.5.1+dfsg-10+rpi10_armhf.deb ...
Unpacking libqt5printsupport5:armhf (5.5.1+dfsg-10+rpi10) ...
Selecting previously unselected package libqt5sql5:armhf.
Preparing to unpack .../libqt5sql5_5.5.1+dfsg-10+rpi10_armhf.deb ...
Unpacking libqt5sql5:armhf (5.5.1+dfsg-10+rpi10) ...
Selecting previously unselected package libqt5webkit5:armhf.
Preparing to unpack .../libqt5webkit5_5.5.1+dfsg-2+rpi10_armhf.deb ...
Unpacking libqt5webkit5:armhf (5.5.1+dfsg-2+rpi10) ...
Selecting previously unselected package qml-module-qtquick2:armhf.
Preparing to unpack .../qml-module-qtquick2_5.5.1-3+rpi10_armhf.deb ...
Unpacking qml-module-qtquick2:armhf (5.5.1-3+rpi10) ...
Selecting previously unselected package qml-module-qtquick-layouts:armhf.
Preparing to unpack .../qml-module-qtquick-layouts_5.5.1-2_armhf.deb ...
Unpacking qml-module-qtquick-layouts:armhf (5.5.1-2) ...
Selecting previously unselected package qml-module-qtquick-window2:armhf.
Preparing to unpack .../qml-module-qtquick-window2_5.5.1-3+rpi10_armhf.deb ...
Unpacking qml-module-qtquick-window2:armhf (5.5.1-3+rpi10) ...
Selecting previously unselected package qml-module-qtquick-controls:armhf.
Preparing to unpack .../qml-module-qtquick-controls_5.5.1-2_armhf.deb ...
Unpacking qml-module-qtquick-controls:armhf (5.5.1-2) ...
Selecting previously unselected package qml-module-qtquick-privatewidgets:armhf.
Preparing to unpack .../qml-module-qtquick-privatewidgets_5.5.1-2_armhf.deb ...
Unpacking qml-module-qtquick-privatewidgets:armhf (5.5.1-2) ...
Selecting previously unselected package qml-module-qtquick-dialogs:armhf.
Preparing to unpack .../qml-module-qtquick-dialogs_5.5.1-2_armhf.deb ...
Unpacking qml-module-qtquick-dialogs:armhf (5.5.1-2) ...
Selecting previously unselected package libqt5sql5-sqlite:armhf.
Preparing to unpack .../libqt5sql5-sqlite_5.5.1+dfsg-10+rpi10_armhf.deb ...
Unpacking libqt5sql5-sqlite:armhf (5.5.1+dfsg-10+rpi10) ...
Setting up libdouble-conversion1:armhf (2.0.1-1) ...
Setting up libqt5qml5:armhf (5.5.1-3+rpi10) ...
Setting up libqt5quick5:armhf (5.5.1-3+rpi10) ...
Setting up libqt5opengl5:armhf (5.5.1+dfsg-10+rpi10) ...
Setting up libqt5printsupport5:armhf (5.5.1+dfsg-10+rpi10) ...
Setting up libqt5sql5:armhf (5.5.1+dfsg-10+rpi10) ...
Setting up libqt5webkit5:armhf (5.5.1+dfsg-2+rpi10) ...
Setting up qml-module-qtquick2:armhf (5.5.1-3+rpi10) ...
Setting up qml-module-qtquick-layouts:armhf (5.5.1-2) ...
Setting up qml-module-qtquick-window2:armhf (5.5.1-3+rpi10) ...
Setting up qml-module-qtquick-controls:armhf (5.5.1-2) ...
Setting up qml-module-qtquick-privatewidgets:armhf (5.5.1-2) ...
Setting up qml-module-qtquick-dialogs:armhf (5.5.1-2) ...
Setting up teamviewer-host (11.0.58397) ...
Setting up libqt5sql5-sqlite:armhf (5.5.1+dfsg-10+rpi10) ...
Processing triggers for libc-bin (2.19-18+deb8u4) ...
pi@raspberrypi:~ $ 

PS: sudo apt-get update und sudo apt-get upgrade von Zeit Zu Zeit ist auch nicht verkehrt :-).

Nun funktioniert die Installation des TeamViewers auch ohne Problem und ich kann den Befehl teamviewer aufrufen.

pi@raspberrypi:~ $ teamviewer 

Init...
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...
Aborted

Mist. Irgendetwas stimmt noch nicht. Ich sehe nur ein kurzes aufblitzen eines neuen Fensters oben rechts und dann ist es auch schon wieder weg. In den Logs sehe ich dann, dass da etwas schief gegangen ist. Das System hat versucht ein Core File zu schreiben – was in der Regel kein gutes Zeichen ist.

Start:              2016/04/29 06:49:10.465  (UTC0:00)
Version:            11.0.58397 Preview H
ID:                 0
Loglevel:           Info (100)
License:            10000
Server:             master7.teamviewer.com
IC:                 -535281200
CPU:                ARMv7 Processor rev 4 (v7l)
OS:                 Lx Raspbian 8 jessie (32-bit)
IP:                 192.168.2.119,192.168.2.118
Proxy-Settings:     Type=0 IP= User=

2016/04/29 06:49:10.471  7985 1793061936 GX0   SessionBusWatcher: suitable bus found with address "unix:abstract=/tmp/dbus-KghIivRTBj,guid=19b2c63fab61357aaddf82cf56ebc33d"
2016/04/29 06:49:10.942  7985 1898942464 GX0   Account::SetLoginState: new state: 2
2016/04/29 06:49:10.955  7985 1898942464 GX0!!!Crash: Coredump '/home/pi/.local/share/teamviewer11/logfiles/TeamViewer_HI_11.0.58397_2016-04-29-064910.armv7.core' could not been written. Error 0
2016/04/29 06:49:10.956  7985 1898942464 GX0   Process received fatal SIGABRT

Auch ein Reboot hilft leider nicht weiter. So wie es scheint, läuft zumindest der Daemon.

pi@raspberrypi:~ $ ps -aef | grep -i team
root       572     1  1 06:53 ?        00:00:01 /opt/teamviewer/tv_bin/teamviewerd -d

Ein Versuch den teamviewer als als root (sudo) auszuführen ist auch nicht erfolgreich. Um etwas mehr Infos auf den Bildschirm zu bekommen habe ich mal ein set -x in das shell Script eingefügt. Aber wirklich weitergeholfen hat es mir auch nicht :-(.

+ InitDirs
+ cd /opt/teamviewer
+ make_path /root/.local/share/teamviewer11/logfiles
+ local path=/root/.local/share/teamviewer11/logfiles
+ local mode=
+ '[' -d /root/.local/share/teamviewer11/logfiles ']'
+ '[' -n '' ']'
+ true
+ make_path /root/.config/teamviewer
+ local path=/root/.config/teamviewer
+ local mode=
+ '[' -d /root/.config/teamviewer ']'
+ '[' -n '' ']'
+ true
+ echo Init...
+ TeeLog reset
++ '[' reset = reset ']'
+ local append=
+ tee /root/.local/share/teamviewer11/logfiles/startup.log
Init...
+ validateUser
+ '[' -n 1000 ']'
+ '[' 1000 '!=' 0 ']'
+ Techo -e ' *** TeamViewer can not be executed with sudo! ***\n Either use your normal user account without sudo\n or use a the real root account to log in to your desktop (not recommended!).\n'
+ echo -e ' *** TeamViewer can not be executed with sudo! ***\n Either use your normal user account without sudo\n or use a the real root account to log in to your desktop (not recommended!).\n'
+ tee --append /root/.local/share/teamviewer11/logfiles/startup.log
 *** TeamViewer can not be executed with sudo! ***
 Either use your normal user account without sudo
 or use a the real root account to log in to your desktop (not recommended!).

+ chown 1000:1000 /root/.local/share/teamviewer11/logfiles/startup.log
+ return 1
+ exit 1

So sieht es aus, wenn man es ohne sudo aufruft.


+ InitDirs
+ cd /opt/teamviewer
+ make_path /home/pi/.local/share/teamviewer11/logfiles
+ local path=/home/pi/.local/share/teamviewer11/logfiles
+ local mode=
+ '[' -d /home/pi/.local/share/teamviewer11/logfiles ']'
+ '[' -n '' ']'
+ true
+ make_path /home/pi/.config/teamviewer
+ local path=/home/pi/.config/teamviewer
+ local mode=
+ '[' -d /home/pi/.config/teamviewer ']'
+ '[' -n '' ']'
+ true
+ echo Init...
+ TeeLog reset
++ '[' reset = reset ']'
+ local append=
+ tee /home/pi/.local/share/teamviewer11/logfiles/startup.log
Init...
+ validateUser
+ '[' -n '' ']'
+ LogStartupInfo
+ HeadEcho TeamViewer: '11.0.58397 - DEB'
+ Log
+ printf '%-18s %s\n' TeamViewer: '11.0.58397 - DEB'
+ cat
+ HeadEcho Profile: '/home/pi (pi)'
+ printf '%-18s %s\n' Profile: '/home/pi (pi)'
+ HeadEcho Desktop: 'DS: '\''LXDE-pi'\'' 	XDG: '\''LXDE'\'''
+ printf '%-18s %s\n' Desktop: 'DS: '\''LXDE-pi'\'' 	XDG: '\''LXDE'\'''
++ InfoXServerTTY
++ local xfvt=
++ cmdExists xprop
++ command -v xprop
+++ xprop -root XFree86_VT
+++ grep INTEGER
+++ cut -f2 -d=
++ xfvt=' 7'
++ xfvt=' 7'
++ echo 7
+ HeadEcho 'XServer TTY:' 7
+ printf '%-18s %s\n' 'XServer TTY:' 7
+ echo
+ echo 'ok (info)'
+ echo
+ CheckEnvironment
+ isQuickSupport
+ '[' DEB == TAR_QS ']'
+ return
+ UpdateBinaries
+ isQuickSupport
+ '[' DEB == TAR_QS ']'
+ Log
+ return 0
+ cat
+ DelayInit
+ isNative
+ '[' HOST == FULL ']'
+ '[' HOST == HOST ']'
+ return 0
+ return
+ echo 'Checking setup...'
Checking setup...
+ InitProfile
+ InitFonts
+ isInstalledTV
+ '[' DEB == DEB ']'
+ return 0
+ return 0
+ SetupEnv
+ make_path /home/pi/.config/teamviewer 0700
+ local path=/home/pi/.config/teamviewer
+ local 'mode=-m 0700'
+ '[' -d /home/pi/.config/teamviewer ']'
+ '[' -n 0700 ']'
+ chmod 0700 /home/pi/.config/teamviewer
+ true
+ make_path /home/pi/.local/share/teamviewer11/logfiles 0700
+ local path=/home/pi/.local/share/teamviewer11/logfiles
+ local 'mode=-m 0700'
+ '[' -d /home/pi/.local/share/teamviewer11/logfiles ']'
+ '[' -n 0700 ']'
+ chmod 0700 /home/pi/.local/share/teamviewer11/logfiles
+ true
+ SetupEnvTAR
+ isInstalledTV
+ '[' DEB == DEB ']'
+ return 0
+ return
+ InitLocalSettings
+ isInstalledTV
+ '[' DEB == DEB ']'
+ return 0
+ [[ 11.0.58397 = 12* ]]
+ ImportTV10SettingsClient
+ local newpath=/home/pi/.config/teamviewer/client.conf
+ local oldpath=/home/pi/.config/teamviewer10/config/client.conf
+ '[' -f /home/pi/.config/teamviewer10/config/client.conf ']'
+ return 1
+ ImportTV9Settings client
+ local conftype=client
+ local globalConf=/opt/teamviewer/config/global.conf
+ local clientConf=/home/pi/.config/teamviewer/client.conf
+ local globalConfOld=/opt/teamviewer9/config/global.conf
+ local copy=n
+ local oldpath
+ local newpath
+ grep -q 9.0.32150 /opt/teamviewer9/config/global.conf
+ '[' client = client ']'
+ newpath=/home/pi/.config/teamviewer/client.conf
+ oldpath=/home/pi/.config/teamviewer9/client.conf
+ '[' -f /home/pi/.config/teamviewer9/client.conf ']'
+ return 1
+ true
+ isNative
+ '[' HOST == FULL ']'
+ '[' HOST == HOST ']'
+ return 0
+ echo 'ok (profile)'
+ echo 'Launching TeamViewer ...'
Launching TeamViewer ...
+ RequireNetwork
+ IsDaemonRunning
+ isInstalledTV
+ '[' DEB == DEB ']'
+ return 0
+ exec
+ return
+ isNative
+ '[' HOST == FULL ']'
+ '[' HOST == HOST ']'
+ return 0
+ echo 'Launching TeamViewer GUI ...'
Launching TeamViewer GUI ...
+ UnlockStartup
+ flock -u -n 300
+ exec
+ isNative
+ '[' HOST == FULL ']'
+ '[' HOST == HOST ']'
+ return 0
+ exec /opt/teamviewer/tv_bin/TeamViewer

Teamviewer deinstallieren

pi@raspberrypi:~ $ sudo apt-get remove teamviewer-host 
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libasn1-8-heimdal libdouble-conversion1 libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal
  libhx509-5-heimdal libkrb5-26-heimdal libqt5opengl5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5sql5 libqt5sql5-sqlite
  libqt5webkit5 libroken18-heimdal libwind0-heimdal qml-module-qtquick-controls qml-module-qtquick-dialogs qml-module-qtquick-layouts
  qml-module-qtquick-privatewidgets qml-module-qtquick-window2 qml-module-qtquick2
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  teamviewer-host
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 19 nicht aktualisiert.
Nach dieser Operation werden 36,6 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] y
(Lese Datenbank ... 128632 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von teamviewer-host (11.0.58397) ...
Removed symlink /etc/systemd/system/multi-user.target.wants/teamviewerd.service.
Clearing assignments ...
done


@raspberrypi:~ $ sudo apt-get autoremove
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden ENTFERNT:
  libasn1-8-heimdal libdouble-conversion1 libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libkrb5-26-heimdal
  libqt5opengl5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5sql5 libqt5sql5-sqlite libqt5webkit5 libroken18-heimdal libwind0-heimdal
  qml-module-qtquick-controls qml-module-qtquick-dialogs qml-module-qtquick-layouts qml-module-qtquick-privatewidgets qml-module-qtquick-window2
  qml-module-qtquick2
0 aktualisiert, 0 neu installiert, 23 zu entfernen und 19 nicht aktualisiert.
Nach dieser Operation werden 47,0 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] j
(Lese Datenbank ... 128544 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von libgssapi3-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libheimntlm0-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libkrb5-26-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libhx509-5-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libqt5webkit5:armhf (5.5.1+dfsg-2+rpi10) ...
Entfernen von qml-module-qtquick-dialogs:armhf (5.5.1-2) ...
Entfernen von qml-module-qtquick-privatewidgets:armhf (5.5.1-2) ...
Entfernen von qml-module-qtquick-controls:armhf (5.5.1-2) ...
Entfernen von qml-module-qtquick-layouts:armhf (5.5.1-2) ...
Entfernen von qml-module-qtquick2:armhf (5.5.1-3+rpi10) ...
Entfernen von libhcrypto4-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libheimbase1-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libqt5opengl5:armhf (5.5.1+dfsg-10+rpi10) ...
Entfernen von libqt5printsupport5:armhf (5.5.1+dfsg-10+rpi10) ...
Entfernen von qml-module-qtquick-window2:armhf (5.5.1-3+rpi10) ...
Entfernen von libqt5quick5:armhf (5.5.1-3+rpi10) ...
Entfernen von libqt5sql5-sqlite:armhf (5.5.1+dfsg-10+rpi10) ...
Entfernen von libqt5sql5:armhf (5.5.1+dfsg-10+rpi10) ...
Entfernen von libwind0-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libasn1-8-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libqt5qml5:armhf (5.5.1-3+rpi10) ...
Entfernen von libdouble-conversion1:armhf (2.0.1-1) ...
Entfernen von libroken18-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Trigger für libc-bin (2.19-18+deb8u4) werden verarbeitet ...

Fazit Alles in allem war die Installation also leider nicht erfolgreich also deinstalliere ich erst mal wieder alles und nutze wieder den guten alten SSL Tunnel um auf meinen Raspberry-PI zuzugreifen 🙂

Meine Apps im Google Play-Strore Jetzt bei Google Play